Thursday 2 June 2016

Implement FC port channel, ISL, and trunking

You have been asked to help resolve a non-optimal Fibre Channel port channel between DC2-MDS-1 and DC2-N5K-2. The desired result is that port channel ID 22 is up at 8Gb/s between the two device and VSAN 1 and 200 are able to traverse through port-channel.


DC2-N5K-2(config)# vsan database

DC2-N5K-2(config-vsan-db)# vsan 200 name VSAN200

DC2-N5K-2(config-vsan-db)# exit

DC2-N5K-2(config)# int san-port-channel 22


DC2-N5K-2(config-if)# channel mode active DC2-N5K-2(config-if)# switchport mode e
DC2-N5K-2(config-if)# switchport trunk mode on DC2-N5K-2(config-if)#switchport speed auto DC2-N5K-2(config-if)# sw trunk allowed vsan 1
DC2-N5K-2(config-if)# sw trunk allowed vsan add 200 DC2-N5K-2(config-if)# no shutdown
DC2-N5K-2(config-if)# int fc1/31-32

DC2-N5K-2(config-if)# channel-group 22 force fc1/31 fc1/32 added to port-channel 22 and disabled
please do the same operation on the switch at the other end of the port-channel, then do "no shutdown" at both ends to bring it up
DC2-N5K-2(config-if)# no shutdown


DC2-MDS-1(config)# vsan database

DC2-MDS-1(config-vsan-db)# vsan 200 name VSAN200

DC2-MDS-1(config-vsan-db)#

DC2-MDS-1(config-vsan-db)# int port-channel 22 DC2-MDS-1(config-if)# channel mode active DC2-MDS-1(config-if)# switchport mode e
DC2-MDS-1(config-if)#switchport speed auto DC2-MDS-1(config-if)# sw trunk allowed vsan 1
DC2-MDS-1(config-if)# sw trunk allowed vsan add 200

DC2-MDS-1(config-if)# sw trunk mode on


DC2-MDS-1(config-if)# no shutdown DC2-MDS-1(config-if)#
DC2-MDS-1(config-if)# int fc1/15-16

DC2-MDS-1(config-if)# channel-group 22 force fc1/15 fc1/16 added to port-channel 22 and disabled
please do the same operation on the switch at the other end of the port-channel,






    1. - Implement Fibre Channel NPV and NPIV features



Configure the two Fibre Channel links between DC2-N5K-1 and DC2-MDS-1 to be two parallel non-trunking. NPV-NPIV links for VSAN 100. The customer demands that servers in VSAN 100 that these links distributed equally at all times, even in the event that one of the links goes down and comes back up

DC2-N5K-1(config)# vsan database

DC2-N5K-1(config-vsan-db)# vsan 100 name VSAN100

DC2-N5K-1(config-vsan-db)# exit DC2-N5K-1(config)# int fc1/31-32 DC2-N5K-1(config-if)# sw mode nP
DC2-N5K-1(config-if)# sw trunk mode off DC2-N5K-1(config-if)# no shutdown DC2-N5K-1(config-if)# exit
DC2-N5K-1(config)# npv auto-load-balance disruptive

Enabling this feature may flap the server interfaces whenever load is not in a balanced state. This process may result in traffic disruption. Do you want to proceed? (y/n): y DC2-N5K-1(config)#
DC2-N5K-1(config)# vsan database

DC2-N5K-1(config-vsan-db)# vsan 100 interface fc1/31 DC2-N5K-1(config-vsan-db)# vsan 100 interface fc1/32





    1. Implement FCoE NPV features



Switch name
ID
Port
DC2-N7K-2
2
E3/9-16
Create a logical device within DC2-N7K-2 that capable in FCoE functionality, use the following parameters





Initialize this logical device with the following parameters:

Mgmt IP:

10.1.1.27
Mgmt Gateway:

10.1.1.254
Telnet:

Enabled
Password:

cisco






DC2-N7K-1(config)# install feature-set fcoe DC2-N7K-1(config)# license fcoe module 3 DC2-N7K-1(config)# system qos
DC2-N7K-1(config-sys-qos)# service-policy type network-qos default-nq-7e-policy DC2-N7K-1(config)#no vdc DC2-N7K-2
DC2-N7K-1(config)# vdc DC2-N7K-2 type storage id 2 DC2-N7K-1(config-vdc)# limit-resource module-type f1 DC2-N7K-1(config-vdc)# allocate interface e3/9-16
DC2-N7K-1(config-vdc)# allocate fcoe-vlan-range 100,200 DC2-N7K-1(config-vdc)#exit
DC2-N7K-1(config)# port-channel load-balance src-dst ip-l4port module 3




DC2-N7K-1# switchto vdc Dc2-n7K-2

---- System Admin Account Setup ----

Do you want to enforce secure password standard (yes/no) [y]: n Enter the password for "admin":
Confirm the password for "admin":



---- Basic System Configuration Dialog VDC: 2 ----



DC2-N7K-2# conf t

DC2-N7K-2(config)# feature telnet DC2-N7K-2(config)# int mgmt 0
DC2-N7K-2(config-if)# ip address 10.1.1.27/24 DC2-N7K-2(config-if)# no shutdown
DC2-N7K-2(config-if)# exit

DC2-N7K-2(config)# ip route 0.0.0.0 0.0.0.0 10.1.1.254

DC2-N7K-2(config)# end DC2-N7K-2# switchback
============================================================

DC2-N5K-1(config)# vlan 100

DC2-N5K-1(config-vlan)# fcoe vsan 100 DC2-N5K-1(config-vlan)# int e1/13-14
DC2-N5K-1(config-if-range)# channel-group 11 mode active DC2-N5K-1(config-if-range)# no shutdown
DC2-N5K-1(config-if-range)# int port-channel 11 DC2-N5K-1(config-if)# switchport
DC2-N5K-1(config-if)# sw mode trunk

DC2-N5K-1(config-if)# sw trunk allowed vlan 100

DC2-N5K-1(config-if)# spanning-tree port type edge trunk


DC2-N5K-1(config-if)# no shutdown DC2-N5K-1(config-if)# exit
DC2-N5K-1(config)# int vfc 11

DC2-N5K-1(config-if)# bind interface port-channel 11 DC2-N5K-1(config-if)# sw mode nP
DC2-N5K-1(config-if)# sw trunk allowed vsan 100 DC2-N5K-1(config-if)# no shutdown
DC2-N5K-1(config-if)# exit

DC2-N5K-1(config)# port-channel load-balance ethernet source-dest-port



DC2-N7K-2(config)# feature-set fcoe DC2-N7K-2(config)# feature telnet DC2-N7K-2(config)# feature lldp DC2-N7K-2(config)# feature npiv
DC2-N7K-2(config)# feature fport-channel-trunk DC2-N7K-2(config)# feature lacp


DC2-N7K-2(config)# vsan database

DC2-N7K-2(config-vsan-db)# vsan 100 name VSAN100

DC2-N7K-2(config-vsan-db)# vsan 200 name VSAN200

DC2-N7K-2(config-vsan-db)# vlan 100 DC2-N7K-2(config-vlan)# fcoe vsan 100 DC2-N7K-2(config-vlan)# vlan 200
DC2-N7K-2(config-vlan)# fcoe vsan 200 DC2-N7K-2(config-vlan)#
DC2-N7K-2(config-vlan)# int e3/13-14

DC2-N7K-2(config-if-range)# channel-group 11 mode active DC2-N7K-2(config-if-range)# no shutdown
DC2-N7K-2(config-if-range)# int port-channel 11


DC2-N7K-2(config-if)# sw

DC2-N7K-2(config-if)# switchport DC2-N7K-2(config-if)# sw mode trunk
DC2-N7K-2(config-if)# sw trunk allowed vlan 100 DC2-N7K-2(config-if)# no shutdown
DC2-N7K-2(config-if)# int vfc-port-channel 11

DC2-N7K-2(config-if)# bind interface port-channel 11 DC2-N7K-2(config-if)# sw mode f
DC2-N7K-2(config-if)# sw trunk mode on

DC2-N7K-2(config-if)# sw trunk allowed vsan 100

Warning: This command will remove all VSANs currently being trunked and trunk only the specified VSANs.
Do you want to continue? (y/n) [n] y DC2-N7K-2(config-if)# no shutdown DC2-N7K-2(config-if)#




No comments:

Post a Comment